Cockpit installation on CentOs7/RHEL7

0
486

Cockpit

Cockpit is an open source and free System Monitoring application. It can be helpful to start, stop and monitor services using both command line and web based interface.It is very helpful to the beginners to monitor system health and for diagnostics.

In this article, we will be known about the installation of Cockpit on Cent-OS 7 and RHEL 7.

First made that system is up-to-date by running the following command

#yum -y update

The cockpit is available in Repositories, so we can simply install it by using the command

 #yum -y install cockpit

Sample Output:

[root@localhost ~]# yum -y install cockpit
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.excellmedia.net
 * extras: centos.excellmedia.net
 * updates: centos.excellmedia.net
Resolving Dependencies
--> Running transaction check
---> Package cockpit.x86_64 0:122-3.el7.centos will be installed
--> Processing Dependency: cockpit-ws = 122-3.el7.centos for package: cockpit-122-3.el7.centos.x86_64
--> Processing Dependency: cockpit-storaged = 122-3.el7.centos for package: cockpit-122-3.el7.centos.x86_64
--> Processing Dependency: cockpit-shell = 122-3.el7.centos for package: cockpit-122-3.el7.centos.x86_64
--> Processing Dependency: cockpit-networkmanager = 122-3.el7.centos for package: cockpit-122-3.el7.centos.x86_64
--> Processing Dependency: cockpit-docker = 122-3.el7.centos for package: cockpit-122-3.el7.centos.x86_64
--> Processing Dependency: cockpit-bridge = 122-3.el7.centos for package: cockpit-122-3.el7.centos.x86_64
--> Running transaction check
---> Package cockpit-bridge.x86_64 0:122-3.el7.centos will be installed
---> Package cockpit-docker.x86_64 0:122-3.el7.centos will be installed
--> Processing Dependency: docker >= 1.3.0 for package: cockpit-docker-122-3.el7.centos.x86_64
---> Package cockpit-networkmanager.noarch 0:122-3.el7.centos will be installed
---> Package cockpit-shell.noarch 0:122-3.el7.centos will be installed
---> Package cockpit-storaged.noarch 0:122-3.el7.centos will be installed
--> Processing Dependency: storaged-lvm2 >= 2.1.1 for package: cockpit-storaged-122-3.el7.centos.noarch
--> Processing Dependency: storaged-iscsi >= 2.1.1 for package: cockpit-storaged-122-3.el7.centos.noarch
--> Processing Dependency: storaged >= 2.1.1 for package: cockpit-storaged-122-3.el7.centos.noarch
---> Package cockpit-ws.x86_64 0:122-3.el7.centos will be installed
--> Processing Dependency: libssh >= 0.7.1 for package: cockpit-ws-122-3.el7.centos.x86_64
--> Processing Dependency: libssh.so.4()(64bit) for package: cockpit-ws-122-3.el7.centos.x86_64
--> Running transaction check
---> Package docker.x86_64 2:1.10.3-59.el7.centos will be installed
--> Processing Dependency: docker-common = 2:1.10.3-59.el7.centos for package: 2:docker-1.10.3-59.el7.centos.x86_64
--> Processing Dependency: selinux-policy >= 3.13.1-97 for package: 2:docker-1.10.3-59.el7.centos.x86_64
--> Processing Dependency: oci-systemd-hook >= 1:0.1.4-5 for package: 2:docker-1.10.3-59.el7.centos.x86_64
--> Processing Dependency: oci-register-machine >= 1:0-1.8 for package: 2:docker-1.10.3-59.el7.centos.x86_64
--> Processing Dependency: container-selinux >= 2:1.10.3-59.el7.centos for package: 2:docker-1.10.3-59.el7.centos.x86_64
---> Package libssh.x86_64 0:0.7.1-2.el7 will be installed
---> Package storaged.x86_64 0:2.5.2-2.el7 will be installed
--> Processing Dependency: libstoraged(x86-64) = 2.5.2-2.el7 for package: storaged-2.5.2-2.el7.x86_64
--> Processing Dependency: libstoraged.so.0()(64bit) for package: storaged-2.5.2-2.el7.x86_64
---> Package storaged-iscsi.x86_64 0:2.5.2-2.el7 will be installed
---> Package storaged-lvm2.x86_64 0:2.5.2-2.el7 will be installed
--> Running transaction check
---> Package container-selinux.x86_64 2:1.10.3-59.el7.centos will be installed
--> Processing Dependency: selinux-policy-targeted >= 3.13.1-97 for package: 2:container-selinux-1.10.3-59.el7.centos.x86_64
--> Processing Dependency: selinux-policy-base >= 3.13.1-97 for package: 2:container-selinux-1.10.3-59.el7.centos.x86_64
---> Package docker-common.x86_64 2:1.10.3-59.el7.centos will be installed
---> Package libstoraged.x86_64 0:2.5.2-2.el7 will be installed
---> Package oci-register-machine.x86_64 1:0-1.10.gitfcdbff0.el7 will be installed
---> Package oci-systemd-hook.x86_64 1:0.1.4-6.git337078c.el7 will be installed
---> Package selinux-policy.noarch 0:3.13.1-60.el7 will be updated
---> Package selinux-policy.noarch 0:3.13.1-102.el7_3.7 will be an update
--> Processing Dependency: policycoreutils >= 2.5 for package: selinux-policy-3.13.1-102.el7_3.7.noarch
--> Processing Dependency: libsemanage >= 2.5 for package: selinux-policy-3.13.1-102.el7_3.7.noarch
--> Running transaction check
---> Package libsemanage.x86_64 0:2.1.10-18.el7 will be updated
--> Processing Dependency: libsemanage = 2.1.10-18.el7 for package: libsemanage-python-2.1.10-18.el7.x86_64
---> Package libsemanage.x86_64 0:2.5-4.el7 will be an update
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.1)(64bit) for package: libsemanage-2.5-4.el7.x86_64
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0)(64bit) for package: libsemanage-2.5-4.el7.x86_64
---> Package policycoreutils.x86_64 0:2.2.5-20.el7 will be updated
--> Processing Dependency: policycoreutils = 2.2.5-20.el7 for package: policycoreutils-python-2.2.5-20.el7.x86_64
---> Package policycoreutils.x86_64 0:2.5-9.el7 will be an update
--> Processing Dependency: libselinux-utils >= 2.5-6 for package: policycoreutils-2.5-9.el7.x86_64
---> Package selinux-policy-targeted.noarch 0:3.13.1-60.el7 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.7 will be an update
--> Running transaction check
---> Package libselinux-utils.x86_64 0:2.2.2-6.el7 will be updated
---> Package libselinux-utils.x86_64 0:2.5-6.el7 will be an update
--> Processing Dependency: libselinux(x86-64) = 2.5-6.el7 for package: libselinux-utils-2.5-6.el7.x86_64
---> Package libsemanage-python.x86_64 0:2.1.10-18.el7 will be updated
---> Package libsemanage-python.x86_64 0:2.5-4.el7 will be an update
---> Package libsepol.x86_64 0:2.1.9-3.el7 will be updated
---> Package libsepol.x86_64 0:2.5-6.el7 will be an update
---> Package policycoreutils-python.x86_64 0:2.2.5-20.el7 will be updated
---> Package policycoreutils-python.x86_64 0:2.5-9.el7 will be an update
--> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-9.el7.x86_64
--> Running transaction check
---> Package libselinux.x86_64 0:2.2.2-6.el7 will be updated
--> Processing Dependency: libselinux = 2.2.2-6.el7 for package: libselinux-python-2.2.2-6.el7.x86_64
---> Package libselinux.x86_64 0:2.5-6.el7 will be an update
---> Package setools-libs.x86_64 0:3.3.7-46.el7 will be updated
---> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be an update
--> Running transaction check
---> Package libselinux-python.x86_64 0:2.2.2-6.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-6.el7 will be an update
--> Processing Conflict: libselinux-2.5-6.el7.x86_64 conflicts systemd < 219-20 --> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package systemd.x86_64 0:219-19.el7 will be updated
--> Processing Dependency: systemd = 219-19.el7 for package: systemd-python-219-19.el7.x86_64
--> Processing Dependency: systemd = 219-19.el7 for package: systemd-sysv-219-19.el7.x86_64
---> Package systemd.x86_64 0:219-30.el7_3.6 will be an update
--> Processing Dependency: systemd-libs = 219-30.el7_3.6 for package: systemd-219-30.el7_3.6.x86_64
--> Running transaction check
---> Package systemd-libs.x86_64 0:219-19.el7 will be updated
--> Processing Dependency: systemd-libs = 219-19.el7 for package: libgudev1-219-19.el7.x86_64
---> Package systemd-libs.x86_64 0:219-30.el7_3.6 will be an update
---> Package systemd-python.x86_64 0:219-19.el7 will be updated
---> Package systemd-python.x86_64 0:219-30.el7_3.6 will be an update
---> Package systemd-sysv.x86_64 0:219-19.el7 will be updated
---> Package systemd-sysv.x86_64 0:219-30.el7_3.6 will be an update
--> Running transaction check
---> Package libgudev1.x86_64 0:219-19.el7 will be updated
---> Package libgudev1.x86_64 0:219-30.el7_3.6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================
 Package                              Arch                Version                                  Repository            Size
==============================================================================================================================
Installing:
 cockpit                              x86_64              122-3.el7.centos                         extras                39 k
Updating:
 systemd                              x86_64              219-30.el7_3.6                           updates              5.2 M
Installing for dependencies:
 cockpit-bridge                       x86_64              122-3.el7.centos                         extras               478 k
 cockpit-docker                       x86_64              122-3.el7.centos                         extras               167 k
 cockpit-networkmanager               noarch              122-3.el7.centos                         extras                64 k
 cockpit-shell                        noarch              122-3.el7.centos                         extras               500 k
 cockpit-storaged                     noarch              122-3.el7.centos                         extras                90 k
 cockpit-ws                           x86_64              122-3.el7.centos                         extras               630 k
 container-selinux                    x86_64              2:1.10.3-59.el7.centos                   extras                80 k
 docker                               x86_64              2:1.10.3-59.el7.centos                   extras                12 M
 docker-common                        x86_64              2:1.10.3-59.el7.centos                   extras                63 k
 libssh                               x86_64              0.7.1-2.el7                              extras               194 k
 libstoraged                          x86_64              2.5.2-2.el7                              extras               118 k
 oci-register-machine                 x86_64              1:0-1.10.gitfcdbff0.el7                  extras               1.1 M
 oci-systemd-hook                     x86_64              1:0.1.4-6.git337078c.el7                 extras                28 k
 storaged                             x86_64              2.5.2-2.el7                              extras               370 k
 storaged-iscsi                       x86_64              2.5.2-2.el7                              extras                32 k
 storaged-lvm2                        x86_64              2.5.2-2.el7                              extras                63 k
Updating for dependencies:
 libgudev1                            x86_64              219-30.el7_3.6                           updates               76 k
 libselinux                           x86_64              2.5-6.el7                                base                 161 k
 libselinux-python                    x86_64              2.5-6.el7                                base                 234 k
 libselinux-utils                     x86_64              2.5-6.el7                                base                 151 k
 libsemanage                          x86_64              2.5-4.el7                                base                 144 k
 libsemanage-python                   x86_64              2.5-4.el7                                base                 103 k
 libsepol                             x86_64              2.5-6.el7                                base                 288 k
 policycoreutils                      x86_64              2.5-9.el7                                updates              841 k
 policycoreutils-python               x86_64              2.5-9.el7                                updates              444 k
 selinux-policy                       noarch              3.13.1-102.el7_3.7                       updates              412 k
 selinux-policy-targeted              noarch              3.13.1-102.el7_3.7                       updates              6.4 M
 setools-libs                         x86_64              3.3.8-1.1.el7                            base                 612 k
 systemd-libs                         x86_64              219-30.el7_3.6                           updates              368 k
 systemd-python                       x86_64              219-30.el7_3.6                           updates              109 k
 systemd-sysv                         x86_64              219-30.el7_3.6                           updates               63 k

Transaction Summary
==============================================================================================================================
Install  1 Package (+16 Dependent packages)
Upgrade  1 Package (+15 Dependent packages)

Total download size: 31 M
Downloading packages:
No Presto metadata available for base
updates/7/x86_64/prestodelta                                                                           | 135 kB  00:00:00
Delta RPMs reduced 7.0 M of updates to 3.9 M (43% saved)
(1/33): policycoreutils-2.2.5-20.el7_2.5-9.el7.x86_64.drpm                                             | 433 kB  00:00:01
(2/33): systemd-python-219-19.el7_219-30.el7_3.6.x86_64.drpm                                           |  79 kB  00:00:01
warning: /var/cache/yum/x86_64/7/extras/packages/cockpit-122-3.el7.centos.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
Public key for cockpit-122-3.el7.centos.x86_64.rpm is not installed
(3/33): cockpit-122-3.el7.centos.x86_64.rpm                                                            |  39 kB  00:00:02
(4/33): cockpit-docker-122-3.el7.centos.x86_64.rpm                                                     | 167 kB  00:00:00
(5/33): cockpit-networkmanager-122-3.el7.centos.noarch.rpm                                             |  64 kB  00:00:00
(6/33): systemd-libs-219-19.el7_219-30.el7_3.6.x86_64.drpm                                             | 169 kB  00:00:04
(7/33): cockpit-shell-122-3.el7.centos.noarch.rpm                                                      | 500 kB  00:00:01
(8/33): policycoreutils-python-2.2.5-20.el7_2.5-9.el7.x86_64.drpm                                      | 259 kB  00:00:05
(9/33): cockpit-storaged-122-3.el7.centos.noarch.rpm                                                   |  90 kB  00:00:01
(10/33): cockpit-bridge-122-3.el7.centos.x86_64.rpm                                                    | 478 kB  00:00:04
(11/33): cockpit-ws-122-3.el7.centos.x86_64.rpm                                                        | 630 kB  00:00:01
(12/33): container-selinux-1.10.3-59.el7.centos.x86_64.rpm                                             |  80 kB  00:00:02
Public key for libgudev1-219-30.el7_3.6.x86_64.rpm is not installed                         ] 268 kB/s | 3.6 MB  00:01:34 ETA
(13/33): libgudev1-219-30.el7_3.6.x86_64.rpm                                                           |  76 kB  00:00:04
Public key for libselinux-2.5-6.el7.x86_64.rpm is not installed                             ] 271 kB/s | 3.7 MB  00:01:33 ETA
(14/33): libselinux-2.5-6.el7.x86_64.rpm                                                               | 161 kB  00:00:03
(15/33): libselinux-utils-2.5-6.el7.x86_64.rpm                                                         | 151 kB  00:00:00
(16/33): libsemanage-2.5-4.el7.x86_64.rpm                                                              | 144 kB  00:00:00
(17/33): libsemanage-python-2.5-4.el7.x86_64.rpm                                                       | 103 kB  00:00:00
(18/33): libsepol-2.5-6.el7.x86_64.rpm                                                                 | 288 kB  00:00:00
(19/33): libssh-0.7.1-2.el7.x86_64.rpm                                                                 | 194 kB  00:00:00
(20/33): libstoraged-2.5.2-2.el7.x86_64.rpm                                                            | 118 kB  00:00:00
(21/33): docker-common-1.10.3-59.el7.centos.x86_64.rpm                                                 |  63 kB  00:00:06
(22/33): oci-register-machine-0-1.10.gitfcdbff0.el7.x86_64.rpm                                         | 1.1 MB  00:00:00
(23/33): selinux-policy-3.13.1-102.el7_3.7.noarch.rpm                                                  | 412 kB  00:00:00
(24/33): oci-systemd-hook-0.1.4-6.git337078c.el7.x86_64.rpm                                            |  28 kB  00:00:01
(25/33): setools-libs-3.3.8-1.1.el7.x86_64.rpm                                                         | 612 kB  00:00:01
(26/33): storaged-2.5.2-2.el7.x86_64.rpm                                                               | 370 kB  00:00:00
(27/33): storaged-iscsi-2.5.2-2.el7.x86_64.rpm                                                         |  32 kB  00:00:00
(28/33): storaged-lvm2-2.5.2-2.el7.x86_64.rpm                                                          |  63 kB  00:00:00
(29/33): selinux-policy-targeted-3.13.1-102.el7_3.7.noarch.rpm                                         | 6.4 MB  00:00:07
(30/33): systemd-sysv-219-30.el7_3.6.x86_64.rpm                                                        |  63 kB  00:00:05
(31/33): libselinux-python-2.5-6.el7.x86_64.rpm                                                        | 234 kB  00:00:13
(32/33): docker-1.10.3-59.el7.centos.x86_64.rpm                                                        |  12 MB  00:01:08
(33/33): systemd-219-19.el7_219-30.el7_3.6.x86_64.drpm                                                 | 3.0 MB  00:02:21
Finishing delta rebuilds of 1 package(s) (5.2 M)
------------------------------------------------------------------------------------------------------------------------------
Total                                                                                         193 kB/s |  28 MB  00:02:30
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
Importing GPG key 0xF4A80EB5:
 Userid     : "CentOS-7 Key (CentOS 7 Official Signing Key) <security@centos.org>"
 Fingerprint: 6341 ab27 53d7 8a78 a7c2 7bb1 24c6 a8a7 f4a8 0eb5
 Package    : centos-release-7-2.1511.el7.centos.2.10.x86_64 (@anaconda)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : libsepol-2.5-6.el7.x86_64                                                                                 1/49
  Updating   : libselinux-2.5-6.el7.x86_64                                                                               2/49
  Updating   : systemd-libs-219-30.el7_3.6.x86_64                                                                        3/49
  Updating   : systemd-219-30.el7_3.6.x86_64                                                                             4/49
  Installing : cockpit-bridge-122-3.el7.centos.x86_64                                                                    5/49
  Installing : cockpit-shell-122-3.el7.centos.noarch                                                                     6/49
  Updating   : libgudev1-219-30.el7_3.6.x86_64                                                                           7/49
  Updating   : libsemanage-2.5-4.el7.x86_64                                                                              8/49
  Updating   : libselinux-utils-2.5-6.el7.x86_64                                                                         9/49
  Updating   : policycoreutils-2.5-9.el7.x86_64                                                                         10/49
  Updating   : selinux-policy-3.13.1-102.el7_3.7.noarch                                                                 11/49
  Updating   : selinux-policy-targeted-3.13.1-102.el7_3.7.noarch                                                        12/49
  Updating   : libsemanage-python-2.5-4.el7.x86_64                                                                      13/49
  Installing : cockpit-networkmanager-122-3.el7.centos.noarch                                                           14/49
  Installing : 1:oci-register-machine-0-1.10.gitfcdbff0.el7.x86_64                                                      15/49
  Updating   : libselinux-python-2.5-6.el7.x86_64                                                                       16/49
  Installing : 1:oci-systemd-hook-0.1.4-6.git337078c.el7.x86_64                                                         17/49
  Updating   : setools-libs-3.3.8-1.1.el7.x86_64                                                                        18/49
  Updating   : policycoreutils-python-2.5-9.el7.x86_64                                                                  19/49
  Installing : 2:container-selinux-1.10.3-59.el7.centos.x86_64                                                          20/49
libsemanage.semanage_direct_remove_key: Unable to remove module docker at priority 200. (No such file or directory).
libsemanage.semanage_direct_remove_key: Unable to remove module docker at priority 400. (No such file or directory).
  Installing : libssh-0.7.1-2.el7.x86_64                                                                                21/49
  Installing : cockpit-ws-122-3.el7.centos.x86_64                                                                       22/49
  Installing : 2:docker-common-1.10.3-59.el7.centos.x86_64                                                              23/49
  Installing : 2:docker-1.10.3-59.el7.centos.x86_64                                                                     24/49
  Installing : cockpit-docker-122-3.el7.centos.x86_64                                                                   25/49
  Installing : libstoraged-2.5.2-2.el7.x86_64                                                                           26/49
  Installing : storaged-2.5.2-2.el7.x86_64                                                                              27/49
  Installing : storaged-iscsi-2.5.2-2.el7.x86_64                                                                        28/49
  Installing : storaged-lvm2-2.5.2-2.el7.x86_64                                                                         29/49
  Installing : cockpit-storaged-122-3.el7.centos.noarch                                                                 30/49
  Installing : cockpit-122-3.el7.centos.x86_64                                                                          31/49
  Updating   : systemd-python-219-30.el7_3.6.x86_64                                                                     32/49
  Updating   : systemd-sysv-219-30.el7_3.6.x86_64                                                                       33/49
  Cleanup    : policycoreutils-python-2.2.5-20.el7.x86_64                                                               34/49
  Cleanup    : systemd-python-219-19.el7.x86_64                                                                         35/49
  Cleanup    : selinux-policy-targeted-3.13.1-60.el7.noarch                                                             36/49
  Cleanup    : selinux-policy-3.13.1-60.el7.noarch                                                                      37/49
  Cleanup    : systemd-sysv-219-19.el7.x86_64                                                                           38/49
  Cleanup    : policycoreutils-2.2.5-20.el7.x86_64                                                                      39/49
  Cleanup    : systemd-219-19.el7.x86_64                                                                                40/49
  Cleanup    : setools-libs-3.3.7-46.el7.x86_64                                                                         41/49
  Cleanup    : libselinux-utils-2.2.2-6.el7.x86_64                                                                      42/49
  Cleanup    : libselinux-python-2.2.2-6.el7.x86_64                                                                     43/49
  Cleanup    : libsemanage-python-2.1.10-18.el7.x86_64                                                                  44/49
  Cleanup    : libsemanage-2.1.10-18.el7.x86_64                                                                         45/49
  Cleanup    : libgudev1-219-19.el7.x86_64                                                                              46/49
  Cleanup    : systemd-libs-219-19.el7.x86_64                                                                           47/49
  Cleanup    : libselinux-2.2.2-6.el7.x86_64                                                                            48/49
  Cleanup    : libsepol-2.1.9-3.el7.x86_64                                                                              49/49
  Verifying  : libsepol-2.5-6.el7.x86_64                                                                                 1/49
  Verifying  : libselinux-2.5-6.el7.x86_64                                                                               2/49
  Verifying  : selinux-policy-3.13.1-102.el7_3.7.noarch                                                                  3/49
  Verifying  : cockpit-bridge-122-3.el7.centos.x86_64                                                                    4/49
  Verifying  : systemd-libs-219-30.el7_3.6.x86_64                                                                        5/49
  Verifying  : libstoraged-2.5.2-2.el7.x86_64                                                                            6/49
  Verifying  : libselinux-utils-2.5-6.el7.x86_64                                                                         7/49
  Verifying  : libsemanage-python-2.5-4.el7.x86_64                                                                       8/49
  Verifying  : policycoreutils-python-2.5-9.el7.x86_64                                                                   9/49
  Verifying  : systemd-python-219-30.el7_3.6.x86_64                                                                     10/49
  Verifying  : cockpit-docker-122-3.el7.centos.x86_64                                                                   11/49
  Verifying  : 2:container-selinux-1.10.3-59.el7.centos.x86_64                                                          12/49
  Verifying  : cockpit-storaged-122-3.el7.centos.noarch                                                                 13/49
  Verifying  : systemd-219-30.el7_3.6.x86_64                                                                            14/49
  Verifying  : storaged-iscsi-2.5.2-2.el7.x86_64                                                                        15/49
  Verifying  : policycoreutils-2.5-9.el7.x86_64                                                                         16/49
  Verifying  : 2:docker-common-1.10.3-59.el7.centos.x86_64                                                              17/49
  Verifying  : 2:docker-1.10.3-59.el7.centos.x86_64                                                                     18/49
  Verifying  : systemd-sysv-219-30.el7_3.6.x86_64                                                                       19/49
  Verifying  : cockpit-ws-122-3.el7.centos.x86_64                                                                       20/49
  Verifying  : selinux-policy-targeted-3.13.1-102.el7_3.7.noarch                                                        21/49
  Verifying  : libselinux-python-2.5-6.el7.x86_64                                                                       22/49
  Verifying  : cockpit-networkmanager-122-3.el7.centos.noarch                                                           23/49
  Verifying  : 1:oci-systemd-hook-0.1.4-6.git337078c.el7.x86_64                                                         24/49
  Verifying  : libgudev1-219-30.el7_3.6.x86_64                                                                          25/49
  Verifying  : storaged-lvm2-2.5.2-2.el7.x86_64                                                                         26/49
  Verifying  : cockpit-shell-122-3.el7.centos.noarch                                                                    27/49
  Verifying  : storaged-2.5.2-2.el7.x86_64                                                                              28/49
  Verifying  : libssh-0.7.1-2.el7.x86_64                                                                                29/49
  Verifying  : 1:oci-register-machine-0-1.10.gitfcdbff0.el7.x86_64                                                      30/49
  Verifying  : libsemanage-2.5-4.el7.x86_64                                                                             31/49
  Verifying  : setools-libs-3.3.8-1.1.el7.x86_64                                                                        32/49
  Verifying  : cockpit-122-3.el7.centos.x86_64                                                                          33/49
  Verifying  : systemd-python-219-19.el7.x86_64                                                                         34/49
  Verifying  : selinux-policy-targeted-3.13.1-60.el7.noarch                                                             35/49
  Verifying  : libsemanage-2.1.10-18.el7.x86_64                                                                         36/49
  Verifying  : systemd-sysv-219-19.el7.x86_64                                                                           37/49
  Verifying  : libgudev1-219-19.el7.x86_64                                                                              38/49
  Verifying  : systemd-219-19.el7.x86_64                                                                                39/49
  Verifying  : selinux-policy-3.13.1-60.el7.noarch                                                                      40/49
  Verifying  : libselinux-utils-2.2.2-6.el7.x86_64                                                                      41/49
  Verifying  : setools-libs-3.3.7-46.el7.x86_64                                                                         42/49
  Verifying  : libsepol-2.1.9-3.el7.x86_64                                                                              43/49
  Verifying  : libselinux-python-2.2.2-6.el7.x86_64                                                                     44/49
  Verifying  : systemd-libs-219-19.el7.x86_64                                                                           45/49
  Verifying  : policycoreutils-2.2.5-20.el7.x86_64                                                                      46/49
  Verifying  : libselinux-2.2.2-6.el7.x86_64                                                                            47/49
  Verifying  : policycoreutils-python-2.2.5-20.el7.x86_64                                                               48/49
  Verifying  : libsemanage-python-2.1.10-18.el7.x86_64                                                                  49/49

Installed:
  cockpit.x86_64 0:122-3.el7.centos

Dependency Installed:
  cockpit-bridge.x86_64 0:122-3.el7.centos                     cockpit-docker.x86_64 0:122-3.el7.centos
  cockpit-networkmanager.noarch 0:122-3.el7.centos             cockpit-shell.noarch 0:122-3.el7.centos
  cockpit-storaged.noarch 0:122-3.el7.centos                   cockpit-ws.x86_64 0:122-3.el7.centos
  container-selinux.x86_64 2:1.10.3-59.el7.centos              docker.x86_64 2:1.10.3-59.el7.centos
  docker-common.x86_64 2:1.10.3-59.el7.centos                  libssh.x86_64 0:0.7.1-2.el7
  libstoraged.x86_64 0:2.5.2-2.el7                             oci-register-machine.x86_64 1:0-1.10.gitfcdbff0.el7
  oci-systemd-hook.x86_64 1:0.1.4-6.git337078c.el7             storaged.x86_64 0:2.5.2-2.el7
  storaged-iscsi.x86_64 0:2.5.2-2.el7                          storaged-lvm2.x86_64 0:2.5.2-2.el7

Updated:
  systemd.x86_64 0:219-30.el7_3.6

Dependency Updated:
  libgudev1.x86_64 0:219-30.el7_3.6                                  libselinux.x86_64 0:2.5-6.el7
  libselinux-python.x86_64 0:2.5-6.el7                               libselinux-utils.x86_64 0:2.5-6.el7
  libsemanage.x86_64 0:2.5-4.el7                                     libsemanage-python.x86_64 0:2.5-4.el7
  libsepol.x86_64 0:2.5-6.el7                                        policycoreutils.x86_64 0:2.5-9.el7
  policycoreutils-python.x86_64 0:2.5-9.el7                          selinux-policy.noarch 0:3.13.1-102.el7_3.7
  selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.7                setools-libs.x86_64 0:3.3.8-1.1.el7
  systemd-libs.x86_64 0:219-30.el7_3.6                               systemd-python.x86_64 0:219-30.el7_3.6
  systemd-sysv.x86_64 0:219-30.el7_3.6

Complete!
[root@localhost ~]#

Now start and enable cockpit service:

#systemctl start cockpit
#systemctl enable cockpit

We can access Cockpit web interface by suing URL address https://ip-address:9090

Login with the server credentials. The dashboard of cockpit is looks like

From this window, we have options to monitor services, logs, Networking and storage details. We can also power off or restart the system from this window.

Enjoy Cockpit in your system.